The comment over AddControllers is absurd. Nobody is ever going to read that.

The idea of self-documenting code remains absurd as long as so many developers continue the absurdity of leaving out letters e.g.

int NumGrads;

Instead of

uint GraduateCount;

This habit persists from forty years ago when variable names were limited to eight letters.

I’ve worked at places where a comment for every line was required; it was worse than no comments.

I think comments should be at block level, explaining what a “paragraph” of code is doing. Those function header things generated by visual studio are often absurd, compulsive, superfluous if functions and parameters have reasonable names.

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store